Berrygps-imu magnometer + accelerometer doesnt work

Forums Technical Support for BerryGPS and BerryGPS-IMU Berrygps-imu magnometer + accelerometer doesnt work

This topic contains 8 replies, has 3 voices, and was last updated by  Mark Williams 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6100

    boomboomrwr
    Participant

    So i have soldered the bridge to make magnometer use 1D, bue currently the compass only points at 31 and the accelerometer just doesnt work?

    Currently using this for school project any help would be great! Thanks!

    #6101

    Mark Williams
    Keymaster

    what do you mean by 1D?

    What code did you use to test your compass and accelerometer?

    Mark --OzzMaker.com --

    #6102

    boomboomrwr
    Participant

    Sorry I mean the address from i2cdetect, I soldered the jumper addr2 closed because for some reason it wasnt detecting the magneometer and accelerometer.

    I used the code from the git clone provided, i changed the address in the library from 0x1E to 0x1D compiled it and ran it.

    #6104

    Mark Williams
    Keymaster

    ok.. understood.

    What is the out put from ‘sudo i2cdetect -y 1’?

    What is the name of the program you are trying to run?

    Do you get any output from the program?

    Mark --OzzMaker.com --

    #6105

    boomboomrwr
    Participant

    My pi is at school right now ill get back to you on the i2detect.

    I ran the compass tutorial 1 and basically the output for heading was basically 30-40 occasionaly it spikes to 300 or drops to 20. I tried moving it in all directions even with rotating but that doesnt seem to change anything? The results seem to be in the same range no matter how i moved the berrygps-imu.

    Ive also ran it with the compass tutorial with compass interface, the needle only pointed in one direction the entire time i rotated or moved the berry.

    By the way thanks for the response!

    #6702

    Vittorio
    Participant

    Sorry for my bad english. I have a problem with the Compass.

    I tried to move and rotate it several times but without results.

    Can you help me please?

    Thanks.

    Vittorio

    Attachments:
    You must be logged in to view attached files.
    #6729

    Mark Williams
    Keymaster

    can you please show the raw readings from X,Y,Z on the magnetometer?

    Mark --OzzMaker.com --

    #6730

    Vittorio
    Participant

    Data from compass_tutorial01_basics.

    Attachments:
    You must be logged in to view attached files.
    #6732

    Mark Williams
    Keymaster

    there looks to be a problem with the IMU, we will have to send another one.
    can you please send your order receipt to sales@ozzmaker.com.

    Mark --OzzMaker.com --

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Blip, blop, bloop…