No NMEA data from BerryGPS-IMU

Forums Technical Support for BerryGPS and BerryGPS-IMU No NMEA data from BerryGPS-IMU

Tagged: 

This topic contains 6 replies, has 4 voices, and was last updated by  Zei 10 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #6947

    Adrien T.
    Participant

    Hi,

    I mounted the BerryGPS-IMU on a Raspberry Pi Zero W.

    I’ve got /dev/serial0, but no NMEA data (cat or gpsmon)

    output of “gpspipe -r” :

    {“class”:”VERSION”,”release”:”3.16″,”rev”:”3.16-4″,”proto_major”:3,”proto_minor”:11}
    {“class”:”DEVICES”,”devices”:[{“class”:”DEVICE”,”path”:”/dev/serial0″,”activated”:”2017-11-01T18:33:40.693Z”,”native”:0,”bps”:9600,”parity”:”N”,”stopbits”:1,”cycle”:1.00}]}
    {“class”:”WATCH”,”enable”:true,”json”:false,”nmea”:true,”raw”:0,”scaled”:false,”timing”:false,”split24″:false,”pps”:false}

    Regards,

    Adrien

    #6950

    Mark Williams
    Keymaster

    We do test every BerryGPS-IMU before they leave.

     

    Can you do a loopback on the serial lines?   Connect RX and TX together with a jumper cable. These is physical pins 8 & 10.   And then run minicom.  When you type, you should see the characters in minicom.  If they dont appear, it means serial is working correctly.

    Install minicom;
    sudo apt-get install minicom

    Start minicom;
    minicom -b 9600 -o -D /dev/serial0

     

    You may need to kill gpsd first;
    sudo killall gpsd

    Mark --OzzMaker.com --

    #7005

    Zei
    Participant

    hi,

    I am having the same problem and tested the minicom with no characters on the screen.  I’ve placed the device outside to get a lock but I am having issues with pi locking up.  I monitored the temperature of the pi prior to it locking up and it is sitting about about 30c. I also placed an amp meter in the power circuit to make sure the power draw was not too much and it is running at about 1.8amps coming off of a 3s battery.

    I also tried two different boards with raspian stretch and jessie.  Unfortunately both boards are only unstable when connected.

    Any recommendations would be appreciated.  Below is the output from gpsmon

    tcp://localhost:2947 JSON slave driver>
    (115) {“class”:”VERSION”,”release”:”3.11″,”rev”:”3.11-3″,”proto_major”:3,”proto_
    minor”:9,”remote”:”tcp://localhost:2947″}
    (122) {“class”:”DEVICES”,”devices”:[{“class”:”DEVICE”,”path”:”tcp://localhost:29
    47#/dev/tty0″}],”remote”:”tcp://localhost:2947″}
    (154) {“class”:”WATCH”,”enable”:true,”json”:false,”nmea”:false,”raw”:2,”scaled”:
    false,”timing”:false,”split24″:false,”pps”:true,”remote”:”tcp://localhost:2947″}

    CGPS

    :9{“class”:”WATCH”,”enable”:true,”json”:true,”nmea”:false,”raw”:0,”scaled”:false,”false,”raw”:0,”scaled”:false,”timing”:false,”split24″:false,”pps”:false}{“class”:”WATCH”,”enable”:true,”json”:true,”nmea”:false,”raw”:0,”scaled”:false,”timing”:false,”split24″:false,”pps”:false}

    Thank you.

     

    #7006

    PeterP
    Participant

    No need to go outside to do this test.

    Do you see anything when you kill gpsd and then display raw serial output?

    Do;
    sudo killall gpsd
    And then
    cat /dev/serial0

     

     

     

    Peter --OzzMaker.com --

    #7017

    Zei
    Participant

    I attached a picture of the output.  After it outputs the data every pi I’ve tried locks up.

    Thank you.

    Attachments:
    #7019

    PeterP
    Participant

    The GPS unit appears to be working.  However it looks you still have console enabled for the raspberry pi.

     

    Have you done everything on this page?
    http://ozzmaker.com/berrygps-setup-guide-raspberry-pi/

    • This reply was modified 10 months, 1 week ago by  PeterP.

    Peter --OzzMaker.com --

    #7021

    Zei
    Participant

    Peter I appreciate your quick response.  I came across the article below and this seems to fix the kernel crashes as well as the communication with the GPS.  Everything is working great now for about 3 hours.

    http://wiki.dragino.com/index.php?title=Getting_GPS_to_work_on_Raspberry_Pi_3_Model_B

    Thank you again for your help.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Blip, blop, bloop…