Reply To: OZZMAKER SARA-R5 serial port issues

Home Forums Forums Technical Support for BerryGPS and BerryGPS-IMU OZZMAKER SARA-R5 serial port issues Reply To: OZZMAKER SARA-R5 serial port issues

Alex Babij

Yeah still having the same issues unfortunately, I do get the same issues to occur with gpsmon only, and I will also get the same error “device or resource busy” just based on time. I had the gps module and PI powered on, but made sure that the GPS itself was “off” with ‘AT+UGPS?” returning 0, didnt run gpsmon or cgps, etc. After waiting long enough I would eventually still get the same “device or resource busy” error on ttyGSM3, although I could still send commands and get responses back like normal in ttyGSM1. If I kept trying to enter ttyGSM3 with minicom, it would eventually work, but I would get no data in there (as expected since gps is off). I didn’t disable gpsd during this, so that may be the reason for getting the “device or resource busy” error, but that doesn’t seem to be the cause of the serial connection becoming unresponsive.

Another thing I tried was after having the channels eventually becoming unresponsive after using gpsmon, I ran ‘sudo killall gpsd’ then tried to enter ttyGSM3 with minicom. That did actually work, but it would show completely random characters, unlike other instances in my previous posts where they would be mostly correct strings with the first line of a new batch of strings having some random characters at the front of it.

Blip, blop, bloop…