Reply To: Unable to Access GNSS Receiver

#18752
g189ffin
Participant

Hi,

I can’t get any serial output from GPS – I get nothing when I run cat /dev/serial0. I have done:

sudo raspi-config
Select interfacing options -> Serial -> No -> Yes

but when I send the dmesg | grep tty  command, I get this:

[ 0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835.enable_headphones=0 snd_bcm2835.enable_headphones=1 snd_bcm2835.enable_hdmi=1 snd_bcm2835.enable_hdmi=0 smsc95xx.macaddr=E4:5F:01:C3:00:2D vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 console=tty1 root=PARTUUID=076c460e-02 rootfstype=ext4 fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles cfg80211.ieee80211_regdom=GB
[ 0.000377] printk: console [tty1] enabled
[ 1.593194] fe201000.serial: ttyAMA1 at MMIO 0xfe201000 (irq = 36, base_baud = 0) is a PL011 rev2
[ 1.593409] serial serial0: tty port ttyAMA1 registered
[ 1.601781] fe215040.serial: ttyS0 at MMIO 0xfe215040 (irq = 37, base_baud = 62500000) is a 16550
[ 5.334007] systemd[1]: Created slice system-getty.slice – Slice /system/getty.

I am able to see i2c devices – haven’t tried GPS on I2C. Please can you help?

Blip, blop, bloop…