Booting with BerryGPS-IMU connected on Ubuntu 20.04

Forums Technical Support for BerryGPS and BerryGPS-IMU Booting with BerryGPS-IMU connected on Ubuntu 20.04

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16809
    hunt_for_the_fix
    Participant

    Hello!

    I recently tried to set up a new Raspberry Pi 4B with the OzzmakerGPS-IMU v2.2 shield plugged directly onto the GPIO pins. I use Rspberry Pi's official Ubuntu 20.04 LTS Ubuntu Server distro (we need to run Ubuntu 20.04 in our setup). It worked so far: When I boot it up, stick the shield onto the Pi and check with sudo i2cdetect -y 1, I get three active addresses. So far so good. ๐Ÿ™‚

    However, when I stick the board onto the Pi BEFORE boot (in particular before U-Boot has finished), the boot process halts and I cannot do anything (I waited for 5 minutes or so with no change). No keyboard typing seems to have an effect. Disconnecting power and connecting it again is the only option to shut it down in that state. I do not see a useful warning in the on-screen logs either. It is 100% reproducible and once I take the shield off, everything works fine again. I tested it with two different shields and Pis each to hopefully make sure it's no hardware issue on the shield or platform.

    This is the output that I see before the freeze. I appears less than one second after power is connected:

    
    Net: eth0: ethernet@7d580000
    starting USB...
    No working controllers found
    Hit any key to stop autoboot: 0
    U-Boot>
    

    I see almost the same without the shield connected, but then it continues while with the shield, it stops here. Without the shield, I do not the the U-Boot prompt (?) but instead it goes on with Switch to partitions #0, OK and continues to boot normally.

    Maybe someone has experienced such a failure before and knows what might cause it? I have honestly never fiddled with the U-Boot process before so I'm a bit stuck here.

    Best
    Felix D.

    PS: Hope I got the formatting right.

    #16950
    vibitz
    Participant

    I am getting the same issue with RPI 4

    #16951
    vibitz
    Participant
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...