Empty Data from GPS

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #11009
    Pascal Brunner

    Hi Ozzmaker-Team,

    I use the BerryGPS-IMU v3.

    The accelerometers are in use, so the IMU should be connected correctly. I am also using the PiScreen and the ceramic antenna.

    I followed the GPS tutorials, but I cannot even get the raw data.

    Here some information:

    cat /boot/config.txt

    # For more options and information see
    # http://rpf.io/configtxt
    # Some settings may impact device functionality. See link above for details

    # uncomment if you get no picture on HDMI for a default “safe” mode

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border

    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.

    # uncomment if hdmi display is not detected and composite is being output

    # uncomment to force a specific HDMI mode (this will force VGA)

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display

    # uncomment for composite PAL

    #uncomment to overclock the arm. 700 MHz is the default.

    # Uncomment some or all of these to enable the optional hardware interfaces

    # Uncomment this to enable the lirc-rpi module

    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)

    # Enable DRM VC4 V3D driver on top of the dispmanx display stack


    #Added for GPS (hopefully)
    #Added for BerryIMU

    #Added for PiScreen


    cat /boot/cmdline.txt

    dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

    cat /etc/default/gpsd (But even no raw data is coming)

    # Default settings for the gpsd init script and the hotplug wrapper.

    # Start the gpsd daemon automatically at boot time

    # Use USB hotplugging to add new USB devices automatically to the daemon

    # Devices gpsd should collect to at boot time.
    # They need to be read/writeable, either by user gpsd or the group dialout.

    # Other options you want to pass to gpsd



    dmesg | grep tty

    [ 0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
    [ 0.000480] console [tty1] enabled
    [ 0.693158] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 81, base_baud = 0) is a PL011 rev2
    [ 0.696522] 3f215040.serial: ttyS0 at MMIO 0x0 (irq = 53, base_baud = 31250000) is a 16550


    ls -l /dev/serial*

    lrwxrwxrwx 1 root root 5 Oct 6 11:17 /dev/serial0 -> ttyS0
    lrwxrwxrwx 1 root root 7 Oct 6 11:17 /dev/serial1 -> ttyAMA0


    ls -l /dev/i2c*

    crw-rw—- 1 root i2c 89, 1 Oct 6 11:17 /dev/i2c-1



    cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with “#” are ignored.



    ps ax | grep gpsd
    5826 pts/0 S+ 0:00 grep –color=auto gpsd


    cat /dev/serial0


    cat /dev/serial0 or serial1 shows just nothing…

    Could it be a problem with the cloudy sky (I waited like 20 minutes, the antenna is attached and the switch set to “EXT”), or should

    cat /dev/serial0

    at least show something?

    I selected:
    Select interfacing options -> Serial -> No -> Yes

    minicom -b 9600 -o -D /dev/serial0

    is also empty and serial0 is shown as offline.

    Thank you for your help!

    Best wishes,


    Mark Williams

    the serial pin on the Raspberry Pi isnt broken out to the male header on PiScreen.  To access the serial pins of the Pi while the PiScreen is connected, you will need to solder a jumper to the bottom of the female header on the PiScreen.


    To test GPS, try it without the PiScreen connected

    Mark --OzzMaker.com --

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…