GPSberry not working on my PI4

Forums Technical Support for BerryGPS and BerryGPS-IMU GPSberry not working on my PI4

Tagged: 

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #15427
    bend94
    Participant

    Hi

    I am back...

    i did receive a new GPSberry card.

    i try first on a PI3, i plugged it and to configured it. GREAT !!! now it is working (see the image attach)

    OK my new GPSberry is operational.

    Now i go back to my new PI4 and unfortunatly this is the same issue , with strange characters (with minicom or with cat /dev/serial0).

    even if i try to upgrade again the Raspbian , this is the same issue

    Do you have any clues ?

    Thanks

    Attachments:
    #15433
    PeterP
    Participant

    It may have something to do with the CPU frequency. try this

    open config.txt

    sudo nano /boot/config.txt
    add this
    core_freq=250
    reboot

    Peter --OzzMaker.com --

    #15436
    bend94
    Participant

    hi

    i added this line and reboot

    core_freq=250

     

    but minicom display same strange chars

    regards

    #15456
    bend94
    Participant

    Hi Again

    I did a Fresh reinstallation of Raspbian on my PI.

    Setup again Serial and GPS daemon

    Still strange characters using Minicom or cat /dev/serial0

    Need help please, should be great to be able to use my PI4 with BERRYgps

    thanks in advance

    #15509
    Mark Williams
    Keymaster

    what Raspbian image file are you using? I will test it here on a Pi 4

    Mark --OzzMaker.com --

    #15527
    bend94
    Participant

    hi

    i used Raspbian GNU/Linux 10 (buster)
    i downloaded it from https://www.raspberrypi.org/downloads/raspbian/

    thx (let me know)

    • This reply was modified 1 year, 3 months ago by bend94.
    Attachments:
    #15546
    Mark Williams
    Keymaster

    I tested on two Pi 4. This is what i did to get it working.

     

    1. burn image 2020-02-13-raspbian-buster-full.img
    2. Enable ssh and wireless
    3. ran raspi-config and disable console of serial and then enabled serial interface
    4. rebooted
    5. view serial while BerryGPS-IMU plugged in, using  cat /dev/serial0
    6. The GPS was reporting errors
    7. I disabled echo with stty -F /dev/serial0
    8. viewing serial now works

    Mark --OzzMaker.com --

    #15550
    bend94
    Participant

    hi Thanks again,
    i will do it again following your procedure
    one last question ,the image

    2020-02-13-raspbian-buster-full.img

    has been download from

    https://www.raspberrypi.org/downloads/raspbian/

    ???
    did you choose

    1/ Raspbian Buster with desktop and recommended software
    2/ Raspbian Buster with desktop
    or
    3/ Raspbian Buster Lite

    i will start reinstallation the evening and i will let you know
    regards

    #15567
    Mark Williams
    Keymaster

    I chose this
    Raspbian Buster with desktop and recommended software

    Mark --OzzMaker.com --

    #15586
    bend94
    Participant

    hi

    YOU ARE A GENIUS ! THX SO MUCH

    I really don't know what happened but following your procedure now it is working on PI4

    Best regards

Viewing 10 posts - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...