[Resolved]Help setting up PiScreen with model B+

Home Forums Forums Technical Support for PiScreen [Resolved]Help setting up PiScreen with model B+

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #2869


    Bear with me please because I am a total newb at this stuff and I’m having trouble setting up my assembled PiScreen on my Raspi Model B+. I installed Raspbian with NOOBS and got the Pi working. All I want to do for now is get the display working. Eventually I want an onscreen keyboard and touch to work, but one thing at a time. Now, I started following this guide to get the drivers installed https://ozzmaker.com/piscreen-driver-install-instructions-2/ and ran into a bunch of issues. Is this the right guide to follow for what I want to do?

    First, on step 4, pi@raspberrypi ~ $ sudo nano /etc/modprobe.d/raspi-blacklist.conf
    I run terminal (something like LxTerminal) and type that command in. It opens a file in the terminal window. I put a # in front of blacklist spi-bcm2708 and close it, but it doesn’t ask me to save which I thought was odd. I reboot, run that command again to open the file and see the # isn’t there. I tried again. So then I browse to /etc/modprobe.d/ and see a few files: raspi-blacklist.conf, raspi-blacklist.conf save, raspi-blacklist.conf save1. The raspi-blacklist.conf file doesn’t have the # while the other two do from my two attempts at adding it. Is this normal behavior? It seems like it isn’t, but I can’t get it to save in raspi-blacklist.conf.

    Next, I run pi@raspberrypi ~ $ sudo nano /etc/modules and paste that whole text block into the file, close and again it saves a second file with the save suffix like before. What am I doing wrong?

    My next issue is I’m not sure where to plug in the PiScreen into my Model B+. Here’s a photo I took of both together: http://i.imgur.com/zAzQe8J.jpg
    Can someone please draw on the picture showing what plugs into what? I can’t get it to power on at all.

    At which point in the process should I plug in the PiScreen and expect something to show up on the display? I have no issue outputting to my TV thru HDMI but the PiScreen doesn’t work (yes I turned the hardware switch on).

    Not sure if this makes a difference, but I was powering the Model B+ from an external USB battery pack. I don’t know if that affects the PiScreen power or whatever. Let me know.


    Mark Williams

    There is a quick start guide here;

    PiScreen Quick Start Guide

    which has a link to an image file you can download with everything already configured.

    In saying that, it is sometimes best to do it manually so you can get an idea of how it works.

    Regarding the files not accepting the changes, you mustn’t be doing something right. How are you saving or closing Nano? I do “Ctrl-X” to exit and then it will ask if I want to save changes.”y” to save changes.
    Or, you can hit “F3” to save without closing Nano.

    Your Pi and PiScreen should work of a battery pack.

    The attached image shows PiScreen sitting on top of a B+

    Mark --OzzMaker.com --


    Thanks. I was just closing the nano screen and it wouldn’t ask me anything. I didn’t do ctrl-x. Is it okay if those extra save file exist or will they mess something up? And at which point in the process should I plug in the PiScreen and expect something to show up on the display?

    Mark Williams

    Does the extra save files end with ‘~’?
    If so, this is nano creating a backup and it shouldn’t effect anything.

    PiScreen should be connected before you turn the power on to your Pi

    Mark --OzzMaker.com --


    The files do not end with a ‘~’.

    So I got the file saved correctly, and after that the PiScreen backlight started working. The screen is black but backlit (so like dark grey). I finished the steps in the guide and ran the test. This appeared on my screen: https://i.imgur.com/BOdAERj.jpg (I see an error but don’t know what it means) and on the Pi: https://i.imgur.com/JMXrIFr.jpg

    After pressing enter on the screen, this was the output https://i.imgur.com/6rwvsIE.jpg

    I’m not sure if this test succeeded since the image appeared on the display, or if it failed because there were errors.

    I still can’t get the desktop image to appear on the piscreen.

    Mark Williams

    The error ‘FATAL: Module g2d_23 not found’ can be ignored.

    So, it looks like it is working as the test image is shown.

    Follow this guide to get X windows working on your PiScreen

    Let me know how you go

    Mark --OzzMaker.com --


    Thanks for your help and easy to follow guide. I got it working, but at this step

    pi@raspberrypi ~ $ sudo sh -c ‘echo “sudo /bin/sh /etc/X11/Xsession.d/xinput_calibrator_pointercal.sh” >> /etc/xdg/lxsession/LXDE/autostart’

    it said Permission Denied. I made sure to copy it with the quotes exactly. Either frame, on the next step, it started X Windows on the PiScreen. But, I keep getting this error: http://i.imgur.com/4944UXL.jpg?1 even after rebooting. I haven’t set it to auto start on the piscreen just yet. Is this fixable?

    Also, I was wondering two things:
    1) Is there a way to easily switch back to HDMI from the PiScreen?
    2) Is there a way to fit the desktop better to the PiScreen? Maybe like a bit zoomed out than it is now. As you can see in the screenshot with the error here http://i.imgur.com/4944UXL.jpg?1 , there are only about 6 icons on the screen, whereas through HDMI I see my entire desktop with about 10 icons. Even the Minecraft icon is off the screen at the bottom. Or possible a way to scroll around the screen to see more of it?

    Thanks again.

    Mark Williams

    Your the second person to tell me that they get a permission error for that command.
    That command is to start to touchscreen calibration utility for X.
    Try and do it manually;

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    and add to the bottom of the file, on a new line, this text;

    sudo /bin/sh /etc/X11/Xsession.d/xinput_calibrator_pointercal.sh

    Re the error after X starts;
    I have no idea why you are getting that error, you can fix it by;
    Go into “Preferences->Desktop Session Settings” and un-check “PolicyKit Authentication Agent”

    1)The console can be moved back to the HDMI port by deleting the text below from /boot/cmdline.txt
    fbcon=map:10 fbcon=rotate:2 fbcon=font:ProFont6x11

    maybe keep to copies of cmdline.txt in your home folder. One with the extra text to display on PiScreen and one without the text so that the console is display on the HDMI.
    Then all you would need to do is a sudp copy. E.g. sudo cp ~/cmdline.txt.piscreen /boot/cmdline.txt
    Leave it to display on HDMI, and then you can move the console to PiScreen with con2fbmap 1 1 and back to the HDMI with con2fbmap 1 0
    And if you dont have X windows set to load automatically, you can always load it to PiScreen with with `FRAMEBUFFER=/dev/fb1 startx’ This works no matter where you have the console set to display.

    2)Yes… you can change the icon size. This will fit more in the display area;
    open /home/pi/.config/libfm/libfm.conf
    nano /home/pi/.config/libfm/libfm.conf
    And add this to the end


    If the file is empty.. this is okay, just add the above text, save and restart X windows.

    You can also play around with the DPI of X Windows

    sudo FRAMEBUFFER=/dev/fb1 startx -- -dpi 60

    Mark --OzzMaker.com --


    I’m not sure what happened, but after doing

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    and add to the bottom of the file, on a new line, this text;

    sudo /bin/sh /etc/X11/Xsession.d/xinput_calibrator_pointercal.sh

    and rebooting, I got this error: https://i.imgur.com/VzaaCLG.jpg I don’t know if it’s realted to what I did but it happened. I googled it and after a few commands, was able to log in.

    I’m not sure I understood what you said. What I did was I didn’t set it up to boot up and show X Windows on the PiScreen right away. Each time I boot up, it works on HDMI and to get it to display on PiScreen I run

    FRAMEBUFFER=/dev/fb1 startx

    and it works. That’s what I like. I was just wondering if there’s a similar simple command to run that makes it go back to HDMI and display on my TV after running

    FRAMEBUFFER=/dev/fb1 startx

    . So in other words, I boot up my Pi, log in, it works on HDMI, I run

    FRAMEBUFFER=/dev/fb1 startx

    to switch over to PiScreen, and now when I want to switch back to HDMI, what is the simplest thing to do here?

    Here is my commanline.txt file: https://i.imgur.com/LoWit6R.jpg (that’s all of it on screen). I don’t have

    fbcon=map:10 fbcon=rotate:2 fbcon=font:ProFont6x11

    to remove.

    Also, thanks for the PolicyKit Authentication Agent tickbox suggestion. It got rid of the error. And resizing the icons works as well, so thank you.

    Mark Williams

    I have never tried what your are describing. So I just tested it.

    Is this what you are seeing;
    1) Pi boots up, X Window loads on HDMI. Keyboard and mouse work within this X Windows Session.
    2) From the terminal within the above X Windows session, you enter FRAMEBUFFER=/dev/fb1 startx
    3) X Windows loads into PiScreen and now mouse and keyboard only work on X windows session in PiScreen

    And then you want to close down the X Windows session on PiScreen to return to X Windows on the HDMI?
    If so, have you tried logging out of the PiScreen X Windows session?

    Mark --OzzMaker.com --


    Yep! That did it. Sorry for the confusion. I thought Logout would log out of the desktop (on both PiScreen and HDMI) and close all my programs, kicking me back to the first login screen after boot up. This is exactly what I was looking for. Thanks very much!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…