No GPS fix & serial console is garbage

Home Forums Forums Technical Support for BerryGPS and BerryGPS-IMU No GPS fix & serial console is garbage

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18794
    jlester.ak
    Participant

    Hey all! I recently found an old BerryGPU-IMUv4 in my bin of electronics. It’s been kicking around that bin for a year. I’m concerned something has broken off of it, or it’s otherwise become borked by jostling around loose.

    I am getting garbage through the serial console. I ran through the setup instructions and am pretty confident I got it all configured correctly. I remember about a year ago I had this device configured & working. I tried a vanilla Rasperry Pi OS image, as well as a custom ADSB-FEEDER image. Same results regardless of OS.

    I have tried multiple baud rates, just to be sure. I have tried grounding the GPS hardware RST_N pin. I’ve let it sit in the sun for an hour. I’m still just getting garbage in the serial console.

    Are there any other troubleshooting steps I can try before giving up on this guy and getting a new one?

    TIA!!

    jake

    #18796
    Mark Williams
    Keymaster

    Hi, can you show us what the garbage looks like?

    Can you also show the output of ‘stty -aF /dev/serial0’

    Mark --OzzMaker.com --

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…