[Resolved]PiScreen - No Picture / No Backlight

Forums Technical Support for PiScreen [Resolved]PiScreen - No Picture / No Backlight

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2865
    bored
    Participant

    Hi Folks,
    Looking for a bit of support.

    I put the piscreen together, however, there's no picture or backlight.

    I've installed the drivers, following the instructions at https://ozzmaker.com/piscreen-driver-install-instructions-2/

    The touchscreen looks like it's working though (I can see things happening when I cat /dev/input/event0)

    Any help would be appreciated.

    ls -l /dev/input/event*
    crw-rw---T 1 root input 13, 64 Nov 3 21:50 /dev/input/event0

    cat /proc/bus/input/devices

    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="ADS7846 Touchscreen"
    P: Phys=spi0.1/input0
    S: Sysfs=/devices/platform/bcm2708_spi.0/spi_master/spi0/spi0.1/input/input0
    U: Uniq=
    H: Handlers=mouse0 event0
    B: PROP=0
    B: EV=b
    B: KEY=400 0 0 0 0 0 0 0 0 0 0
    B: ABS=1000003
    #2866
    Mark Williams
    Keymaster

    Hi
    Can you please show us the output of

    dmesg
    and
    cat /etc/modules

    BTW: you checked that the backlight switch is in the on position?

    Mark --OzzMaker.com --

    #2868
    bored
    Participant

    Hi Mark,

    Thanks for the quick reply.

    Yes, definitely checked the switch is in the "on" position! ๐Ÿ™‚

    dmesg output is here:
    http://pastebin.com/6ZfKB1jb

    /etc/modules is here:
    http://pastebin.com/eYy2CkJq

    #2885
    Mark Williams
    Keymaster

    That all looks good, everything loaded properly.
    The back light should come one even if nothing is being displayed.

    the led:22 in the line below (from /etc/modules) will force the drivers to use GPIO22 to control the back light.
    fbtft_device debug=3 rotate=90 name=flexfb speed=16000000 gpios=reset:25,dc:24,led:22

    When you installed the drivers, was it from a clean image? We just need to work out if anything else is using that GPIO.

    BTW: do you have the Kit or the Assembled PiSCreen

    Mark --OzzMaker.com --

    #2887
    bored
    Participant

    Hi Mark,

    I have the assembled PiScreen.
    The drivers were installed to a clean image of 2014-09-09-wheezy-raspbian.

    I can confirm that manually toggling GPIO22 (pin 15) on and off from a python console does toggle the backlight on and off.
    However, the command:
    echo 0 | sudo tee /sys/class/backlight/*/bl_power
    both produce this error:

    tee: /sys/class/backlight/*/bl_power: No such file or directory
    0

    and it's the same for echo 1 as well.

    After turning the backlight on manually, there's still no image using fbi.

    I should probably also mention that I'm doing all of this through an ssh console - there's no monitor hooked up to the pi.

    I will try a copy of your image tomorrow night, and post back.

    Cheers,

    Bored

    #2893
    Mark Williams
    Keymaster

    Mmmmm.
    I just tried echo 0 | sudo tee /sys/class/backlight/*/bl_power and it worked fine for me, but I am running an earlier version of Raspbian, but it has been udpated.

    I will have to test with the latest image file.

    Mark --OzzMaker.com --

    #2898
    bored
    Participant

    hmmm... the image from your website works fine... so not a hardware issue.

    Any other ideas?

    Cheers

    #2905
    Mark Williams
    Keymaster

    I just tried with a vanilla install of 2014-09-09-wheezy-raspbian.
    And it worked fine.

    Here is the history of commands i used;

    pi@raspberrypi ~ $ history
        1  sudo rpi-update
        2  sudo reboot
        3  sudo apt-get update
        4  sudo apt-get upgrade
        5  sudo REPO_URI=https://github.com/notro/rpi-firmware rpi-update
        6  sudo reboot
        7  sudo nano /etc/modprobe.d/raspi-blacklist.conf
        8  sudo nano /etc/modules
        9  sudo reboot
       10  sudo apt-get install fbi -y
       11  wget https://ozzmaker.com/Raspi_Logo.png
       12  sudo fbi -noverbose -T 1 -a -d /dev/fb1 Raspi_Logo.png
       13  echo 1 | sudo tee /sys/class/backlight/*/bl_power
       14  echo 0 | sudo tee /sys/class/backlight/*/bl_power
    

    Mark --OzzMaker.com --

    #2923
    bored
    Participant

    Hi Mark,

    Repeating those steps with a new, clean, image it worked fine.
    I have absolutely no idea what went wrong on the previous image.

    Thanks.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...