PiScreen2 on Buster – outdated packages?

Home Forums Forums Technical Support for PiScreen PiScreen2 on Buster – outdated packages?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #9461

    Hi OzzMaker,

    I’m trying to get a PiScreen2 working (RPi 3b+, Raspbian Buster) and have found that the instructions may be a little out of date.

    PiScreen Driver Install Instructions

    Specifically, apt-get can’t seem to find fbi and mplayer2 also isn’t found. I instead installed mplayer, but the reference to the video file was invalid.

    So far I haven’t been able to tell if my PiScreen2 is working or not. (It may be damaged – issue with headers)

    Can an alternate/updated way to test the screen be added to the driver instructions?

    Many thanks,



    Mark Williams

    I just tested FBI and it works for me on buster. what page do you see an issue with the video file?

    PiScreen2 works with Buster.
    Is your screen all white or black?
    White means drivers are not loaded or there is an issue with the screen itself.


    Have you done this step?

    5. Extra step for Jessie
    By default, Jessie will automatically load X out the HDMI port which will then blank out PiScreen which will make it look like it isnt working.

    If you want X to automatically load onto PiScreen. Open up the framebuffer conf file;

    sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf
    Change the below line;
    Option “fbdev” “/dev/fb0”
    Option “fbdev” “/dev/fb1”

    Or, if you would like to disable X from starting automatically, just run sudo raspi-config and look for the option to disable it.

    Mark --OzzMaker.com --


    Thanks Mark,

    I was eventually able to install fbi, it may have been a proxy issue at my end that someone silently fixed (pure speculation). The mplayer2 still won’t install however; not a big deal for me since I’m not planning on playing videos.

    However I haven’t been able to get pygame to display to fb1 (just opens to the HDMI screen on fb0). This was using the example at https://ozzmaker.com/faq/use-python-display-information-piscreen/

    I’ve ended up using the solution posted here:


    I.e. opening the frame buffer directly to update: f = open(“/dev/fb1″,”wb”). Is there something I need to install, perhaps an “SDL” package?

    Mark Williams

    try entering this into the terminal before you start your script
    export DISPLAY=:0

    Mark --OzzMaker.com --


    Sorry, no that didn’t help.

    In any case this probably isn’t a Buster problem. Thanks for your assistance

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…