Possibly Dead Unit?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14137
    Henry
    Participant

    I have been scouring the Forum here and the topic that matches my issue the most is HERE   One thing that is different with my issue is the FIX light never comes on.   I am unable to see the unit via I2C, however, do we really need I2C communications to be functioning for the FIX to connect with the GPS system?  I would think that would be a hardware/firmware connection and not a software connection.  Nevertheless, I have tried a Raspberry Pi Zero, Zero W, 3B 1.1, 3B 1.2, and 4.  None of these combinations work.  I am using 3 different SD cards using the latest Raspian Lite (for the Zeros), or the Raspian Buster Desktop (for the Model 3/4).

    #14144
    Mark Williams
    Keymaster

    Hi, i2c is only used by the IMU.

    The GPS just uses Serial.

    How do you have it setup?

    +internal or external antenna?
    +What position is the antenna switch in?
    +When testing, are you outside with clear access to sky?

    Mark --OzzMaker.com --

    #14200
    Henry
    Participant

    Internal GPS antenna

    I purchased brand new pi zero W – just got it today via Amazon. I am using 2019-09-26-raspbian-buster-lite   Buster.

    I am now out on the patio trying to use it

    No FIX light is blinking – however, power light is on

    running cat /dev/serial0  and screen /dev/serial0 9600  this is what screen is reporting even after 20 minutes of waiting

    $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
    $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E
    $GPGSV,1,1,00*79
    $GLGSV,1,1,00*65
    $GNGLL,,,,,,V,N*7A
    $GNRMC,,V,,,,,,,,,,N*4D
    $GNVTG,,,,,,,,,N*2E
    $GNGGA,,,,,,0,00,99.99,,,,,,*56
    $GNGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*2E

     

     

    • This reply was modified 2 years, 8 months ago by Henry.
    #14204
    Henry
    Participant

    I just got a new Berry Unit via Amazon.  I performed the following:

    download – 2019-09-26-raspbian-buster-lite.zip
    Flash microSSD with Etcher
    Place microSSD into rPi Zero W
    sudo raspi-config
    setup wireless access
    enable ssh
    reboot
    putty into rPi Zero W
    sudo apt-get update
    sudo apt-get upgrade
    reboot
    sudo raspi-config
    interfacing options -> Serial -> No -> Yes
    reboot
    take unit outside on patio
    turn power on
    go back inside house
    putty into rPi Zero W
    cat /dev/serial0
    wait 30 minutes

    === unit is working.  The other unit must be a DOA.

    Thanks,

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…