Post here for support on the OzzMaker SARA-R5 LTE-M GPS + 10DOF

Home Forums Forums Technical Support for the OzzMaker SARA-R5 LTE-M GPS + 10DOF Post here for support on the OzzMaker SARA-R5 LTE-M GPS + 10DOF

Tagged: 

Viewing 15 posts - 31 through 45 (of 49 total)
  • Author
    Posts
  • #18462
    julienvm
    Participant

    Was not able to add images in line so attaching them here.

    #18469
    Mark Williams
    Keymaster

    The header is soldered on here by hand and then each module is tested.

    Can you try i2cdetect -y 1 (not two)

    Mark --OzzMaker.com --

    #18474
    julienvm
    Participant

    Correction:

    i2cdetect -y 1 now works (I forgot to enable I2C and was using i2c detect -y 2 by mistake)

     

    Thanks Mark for your quick feedback!

    Will now look into LTE and GPS

    • This reply was modified 8 months, 3 weeks ago by julienvm.
    #18480
    julienvm
    Participant

    I managed to get IMU and pressure/temp to work. Thanks for your help.

    I’m now trying to get GPS to work. I can see the NMEA stream and it seems to have acquired a location.

    However, gpsmon and cgps can’t seem to access the stream. I followed every step of the instructions (multiplex, set SARA-R5-init.sh, rc.local, etc…)

    Here are some screenshots to help locate the issue.

    I’m happy to answer any question.

    I appreciate your time and effort to help with this.

    #18488
    julienvm
    Participant

    Actually, the NMEA stream never starts automatically. Instead, I get this new file in /tmp/ttyGSM0 with the start instruction which never ran.

    That’s caused by the instruction

    sleep 10
    echo -e “AT+UGPS=1,4,67\r\n” > /tmp/ttyGSM0

    which I assume is incorrect (I suspect it could be /dev/ttyGSM0 instead of /tmp/ttyGSM0 like in the instruction for direct commands)

    #18493
    julienvm
    Participant

    I managed to solve this problem. I’m using a python script and I’m managing all the serial port communication through that.

    Next I’ll look into LTE.

    #18495
    richardp
    Participant

    Good to see you have it working.   And apologies for the error in the guide.  I have just updated it to say /dev/ttyGSM0

    Richard --OzzMaker.com --

    #18498
    julienvm
    Participant

    OK, with LTE, I have this issue.

    Any idea what could be causing it?

    Also, if I connect to the modem (/ttyGSM1) via minicom, what instructions can I send it to check its status and verify it’s correctly connected?

    • This reply was modified 8 months, 2 weeks ago by julienvm.
    #18501
    julienvm
    Participant

    OK I figured out some issues.

    I used the AT command manual for this SARA-R5 modem.

    I tried the first general commands (which manufacturer, which model, which version, which IMEI…).

    Then I tried AT+CCID which is to check the SIM card identification number. This returned ERROR. It didn’t specify which error, so after a while, I looked at the modem and inserted the simcard the other way. Same error. I restarted the pi and now it worked passed this error! (see screenshot).

    #18533
    julienvm
    Participant

    I’ve been wrestling with PPP.

    The connection is established:

    ifconfig
    ppp0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500
    inet 192.168.201.1 netmask 255.255.255.255 destination 192.168.201.2
    ppp txqueuelen 3 (Point-to-Point Protocol)
    RX packets 8 bytes 224 (224.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 10 bytes 351 (351.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    ping 192.168.201.2
    PING 192.168.201.2 (192.168.201.2) 56(84) bytes of data.
    64 bytes from 192.168.201.2: icmp_seq=1 ttl=255 time=22.9 ms

    route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.86.1 0.0.0.0 UG 302 0 0 wlan0
    192.168.86.0 0.0.0.0 255.255.255.0 U 302 0 0 wlan0
    192.168.201.2 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0

    However, the connection isn’t used.

    #18538
    julienvm
    Participant

    I think there’s two ways to use the connection.

    1. Set the connection as default – I haven’t been able to configure the Raspberry Pi to connect via ppp by default. Can you explain how to do that?

    2. Tell the script to use specifically this connection (using requests library and proxies setting)

    #18558
    julienvm
    Participant

    Here is my script.

    It works when proxies=proxies is removed (using wifi), but fails when proxies are set (attempting to use ppp).

    import requests
    proxies = {
    ‘http’: ‘http :// 192.168.201.2 ‘,
    ‘https’: ‘http :// 192.168.201.2 ‘,
    }
    x = requests.get(‘https://google.com ‘, proxies=proxies)
    print(x.text)

    (I added spaces in the definition of proxies as otherwise this reply won’t be accepted by the forum server)

    runtime errors:
    ConnectionRefusedError: [Errno 111] Connection refused
    Failed to establish a new connection: [Errno 111] Connection refused
    HTTPSConnectionPool(host=google.com, port=443): Max retries exceeded with url: / (Caused by ProxyError(Cannot connect to proxy, Failed to establish a new connection: [Errno 111] Connection refused)))

    I’m looking for help for either setting the connection as default, or for using a python script. I just would like the raspberry pi to connect to the internet via ppp.

    Thank you

    #18560
    Mark Williams
    Keymaster

    do you want to use PPP even if you have a wireless connection?
    The output below looks like you have wlan0 and ppp0 connection and the default route is via the wlan0 interface.

    route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.86.1 0.0.0.0 UG 302 0 0 wlan0
    192.168.86.0 0.0.0.0 255.255.255.0 U 302 0 0 wlan0
    192.168.201.2 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0

    If you only have the ppp0, the Pi will use to access the internet

    Mark --OzzMaker.com --

    #18568
    julienvm
    Participant

    I didn’t know that it uses wifi per default but reverts to ppp if that’s the only option available.
    I tried that and it works.
    However, the datarate is super slow (which is perfect for what I need).

    But my first way to try was to use remote VNC, and that failed due to slow datarate.
    Later, I connected a screen, and realized the data does flow through ppp.
    Thanks a lot for the support!

    #18756
    N_J_S
    Participant

    Hi,

    I’m not sure if this is the correct place for this but I’m having issues using the LTE system.

    I’ve carefully followed the instructions for multiplexing and then for setting up the LTE connection but I can never get the connection to work and show up when using the ifconfig command. I always receive the same “/dev/ttyGSM1: no such file or directory” error when using “tail -f /var/log/syslog” to monitor the connection. However I am able to connect to /dev/ttyGSM1 using minicom.

    For reference I am using a Pi Zero 2W with the latest 32 bit headless Pi OS and I haven’t had any issue setting up the GPS.

    If anyone has any advice for dealing with this issues it would be greatly appreciated.

    Thanks!

Viewing 15 posts - 31 through 45 (of 49 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…