setting APN not working

Home Forums Forums Technical Support for BerryGPS-GSM setting APN not working

Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #16029
    midu3030
    Participant

    Hi,

    I just installed the BerryGPS+GSM on a Raspberry pi 0, followed all instructions for hologram, but it does not work. The main failure is with setting the APN. I did a screen on /dev/ttyACM0 and issued some test commands, as suggested by hologram forums. See the log below. I get stuck with the error response on at+cgdcont, that is the main thing that fails, see the last few lines in the log below.

    Running from a 2A power source and added the max_usb_current=1 configuration.

    Any suggestions welcome.

    Thanks,

    Mihai

    at
    OK
    ati
    SARA-U201-04B-00

    OK
    at+cgmi
    u-blox

    OK
    at+cgmm
    SARA-U201

    OK
    at+gmm
    SARA-U201

    OK
    at+cpin?
    ERROR
    at+ccid
    ERROR
    at+cfun?
    +CFUN: 1,0

    OK
    at+csq
    +CSQ: 29,2

    OK
    at+creg?
    +CREG: 0,3

    OK
    at+cgreg?
    +CGREG: 0,3

    OK
    at+cgdcont?
    ERROR
    at+cgact?
    ERROR
    at+cops?
    +COPS: 0

    OK
    at+cops=?
    +COPS: (1,"F-Bouygues Telecom","BYTEL","20820",2),(1,"Orange F","Orange","20801",2),(1,"F SFR","SFR","20810",2),(1,"Orange F","Orange","20801",0),(1,"F SFR","SFR","20810",0),(1,"F-Bouygues Telecom","BYTEL","20820",0),,(0-6),(0-2)

    OK
    at+cgdcont=1,"IP","hologram"
    ERROR

    #16030
    Mark Williams
    Keymaster

    connect to /dev/ttyACM1
    Can you show me the output of the below commands.
    First, enable extended error commands with
    AT+CMEE=2
    The enable unsolicited messages
    AT+UGIND=1
    Check the SIM status
    AT+cpin?

    configure APN
    AT+UPSD=0,1,"hologram"

    Are you registered?
    at+cgreg?

    What is you profile status?
    AT+UPSND=0,8

    Mark --OzzMaker.com --

    #16032
    midu3030
    Participant

    sim not inserted ... weird, see below. hologram sim is definitely in there, the right way.

    AT+CMEE=2
    OK
    AT+UGIND=1
    OK
    AT+cpin?
    +CME ERROR: SIM not inserted
    AT+UPSD=0,1,"hologram"
    OK
    at+cgreg?
    +CGREG: 0,3

    OK
    AT+UPSND=0,8
    +UPSND: 0,8,0

    OK

    #16033
    Mark Williams
    Keymaster

    Can you upload a photo of the sim connector

    Mark --OzzMaker.com --

    #16034
    midu3030
    Participant

    see attachments

    Attachments:
    #16037
    Mark Williams
    Keymaster

    I was hoping for a picture of the connectors

    If possible can you please send it to sales @ ozzmaker.com.

    You may have a faulty unit which may need replacing.

    Mark --OzzMaker.com --

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...