Startx does not work automatically on /etc/rc.local

Home Forums Forums Technical Support for PiScreen Startx does not work automatically on /etc/rc.local

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #4136
    phantom_83
    Participant

    I followed your guide to the letter, it all works perfectly, but when I insert:

    su -l pi -c "env FRAMEBUFFER=/dev/fb1 startx &"

    in
    sudo nano /etc/rc.local

    after restarting the desktop does not start, the screen remains black. The boot is displayed but the screen of raspbian not see and I run it manually via ssh:

    FRAMEBUFFER = / dev / fb1 startx

    and I get:

    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: Open failed for transport inet6 / raspberrypi: 1
    _XSERVTransMakeAllCOTSServerListeners: Failed to open listener for inet6

    X.Org X Server 1.12.4
    Release Date: 2012-08-27
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.2.0-2-mx5 armv7l Debian
    Current Operating System: Linux raspberrypi 18/03/11-v7 + # 781 SMP PREEMPT Tue April 21 18:07:59 BST 2015 armv7l
    Kernel command line: dma.dmachans = 0x7f35 bcm2708_fb.fbwidth bcm2708_fb.fbheight = 656 = 416 = bcm2709.boardrev 0xa01041 bcm2709.serial = 0xb071613c smsc95xx.macaddr = B8: 27: EB: 71: 61: 3C = 1 bcm2708_fb.fbswap bcm2709 .disk_led_gpio = 47 = 0 bcm2709.disk_led_active_low sdhci-bcm2708.emmc_clock_freq = 250000000 = vc_mem.mem_base 0x3dc00000 vc_mem.mem_size 0x3f000000 dwc_otg.lpm_enable = = 0 = ttyAMA0,115200 console console = tty1 root = / dev / mmcblk0p2 rootfstype = ext4 elevator = deadline rootwait fbcon = map: 10 fbcon = rotate: 0 fbcon = font: ProFont6x11
    Build Date: 11 February 2015 09:31:17 PM
    xorg-server 2: 1.12.4-6 + deb7u6 (Julien Cristau <jcristau@debian.org>)
    Current version of pixman: 0.33.1
    Before reporting problems, check http://wiki.x.org
    to make sure That you have the latest version.
    Markers: (-) probed, (**) from config file, (==) default setting,
    (++) From the command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.1.log", Time: Tue Jun 16 22:24:01 2015
    (==) Using config directory system "/usr/share/X11/xorg.conf.d"
    FATAL: Module g2d_23 not found.
    The xkeyboard keymap compiler (xkbcomp) reports:
    > Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
    > Ignoring extra symbols
    Errors from xkbcomp are not fatal to the X server

    But I can work quietly.
    How do I solve the problem?

    #4137
    Mark Williams
    Keymaster

    Does it work when you run in manually?

    Mark --OzzMaker.com --

    #4138
    phantom_83
    Participant

    Yes!!! Manually it ok

    #4139
    Mark Williams
    Keymaster

    can you show me what the contents of /etc/rc.local is. When it has the startx command in it.

    Mark --OzzMaker.com --

    #4148
    phantom_83
    Participant

    sorry for the delay. I was busy at work . Here is the content of rc.local:

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    # Print the IP address
    _IP=$(hostname -I) || true
    if [ "$_IP" ]; then
    printf "My IP address is %s\n" "$_IP"
    fi
    su -l pi -c "env FRAMEBUFFER=/dev/fb1 startx &"
    exit 0

    #4157
    phantom_83
    Participant

    up? thanks!

    #4162
    Mark Williams
    Keymaster

    I am not sure why it isn't working.
    Have you changed the keyboard layout?

    What about our image, have you tried it?
    https://ozzmaker.com/piscreen/PiScreenImage-SDCard-1.8.zip

    Mark --OzzMaker.com --

    #4163
    phantom_83
    Participant

    you have changed the layout ... now I feel your image and see what happens.
    thanks!

    #4170
    phantom_83
    Participant

    with your image works perfectly !!! I wanted to add kodi. it's possible? I have to do something in particular?

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...