startx not loading automatically

Home Forums Forums Technical Support for PiScreen startx not loading automatically

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4373
    assuncao
    Participant

    Hi,

    It works fine when I execute from a SSH terminal FRAMEBUFFER=/dev/fb1 startx , but it does not start automatically on boot. Console on PiScreen works fine, but right after it loads, it changes to HDMI display. How can I fix it? I've tried everything on this page: https://ozzmaker.com/enable-x-windows-on-piscreen/.

    We are using Raspberry Pi 2 (raspbian / wheezy).

    I hope it can be solved. We've got 3 PiScreens 2 to use as tests and we are planning to buy 7 more soon.

    Thanks

    #4374
    Mark Williams
    Keymaster

    have you made the rewuired changes to the two files below?
    /etc/inittab
    &
    /etc/rc.local

    Mark --OzzMaker.com --

    #4375
    assuncao
    Participant

    Hi Mark,

    Thanks for your fast answer! Fortunately I solved my problem. Probably people are having the same issue as was having before. Please consider to add the solution to the instructions. What have I done? I just disabled the option "Desktop Log in as user pi at the graphical desktop", through raspi-config. I had to choose "Console Text console, requiring login (defauly)".

    Best regards,
    Erik

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...