xscreen not starting Pi 2

Home Forums Forums Technical Support for PiScreen xscreen not starting Pi 2

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #3612
    jawood
    Participant

    I am trying to get the piscreen working on a Pi2 it displays pictures ok but when I run command FRAMEBUFFER=/dev/fb1 startx I get error

    GDBus.Error.org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject.

    I continued with the x windows configuration and after reboot still goes to the hdmi output.
    Ow and touch screen is working.

    Any assistance would be appreciated.

    #3614
    Mark Williams
    Keymaster

    Try this;
    Access X windows through the HDMI as you normally would.

    Go into "Preferences->Desktop Session Settings" and un-check "PolicyKit Authentication Agent"

    reboot and try FRAMEBUFFER=/dev/fb1 startx again.

    Please let me know if this works

    Mark --OzzMaker.com --

    #3615
    jawood
    Participant

    Hi and thanks for your reply, but there is no Desktop Session Settings under Preferences?

    #3616
    jawood
    Participant

    Ok I got that sorted can now open the xsession on the piscreen, but I cant get it to boot straight to the piscreen. have edited both inittab and rc.local with no change.

    Any suggestions would be appreciated.

    #3618
    brizio71
    Participant

    jawood

    Hi,

    can you please let me know which version you have install on Pi2 and the procedure for have the screen working ?
    I have try many different distibution using the procedure of this site but my screen remain always blank no image shown.

    Thanks

    Fabrizio

    #3619
    jawood
    Participant

    Hi I just downloaded the lattest version from the raspberry web site

    Raspbian Debian Wheezy Version:February 2015 Release date: 2015-02-16

    and then just followed the instructions on here I got terminal startup screen to run on the piscreen but when it gets to xsession it switches back to the hdmi port. Havent been able to get that fixed yet, but if I type the framebuffer command into the terminal it switches straight over to the piscreen and all works fine calibrated touch and onscreen keyboard all working..

    #3622
    brizio71
    Participant

    I have reinstall the image and follow the step on your guide but on sten n.4 Enable SPI I can not find the file raspi-blacklist.conf, did you find it on your procedure ?

    #3623
    jawood
    Participant

    I went into sudo raspi-config then went to advanced settings and you will see the option there to enable it..

    #3624
    Mark Williams
    Keymaster

    I am in the process of finishing up a new image with the latest software. I hope I finish sometime today.

    I also got the error 'GDBus.Error.org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject.'

    The new user interface no longer has the icon for the session settings. To get to the settings, you need to run lxsession-edit from a terminal within X.

    Mark --OzzMaker.com --

    #3625
    jawood
    Participant

    Thanks I found that with a quick google search, however I still cant get the piscreen to run at startup. Hoping that you can shed some light on that for me.

    Thanks

    #3626
    brizio71
    Participant

    I have try to reinstall for the third time, I have enable the SPI from raspi-config, now I'm on step 4 "Enable SPI", I have find the file /etc/modprobe.d/raspi-blacklist.conf but is empty:
    -rw-r--r-- 1 root root 0 mar 3 23:36 /etc/modprobe.d/raspi-blacklist.conf
    what I have to do ?
    thx

    #3635
    Mark Williams
    Keymaster

    Sorry for the late reply.

    We have updated our image that now works on Pi 2.

    Can you please test it with this image;
    https://ozzmaker.com/piscreen/PiScreenImage-SDCard-1.7.zip

    Mark --OzzMaker.com --

    #3648
    jawood
    Participant

    ok so the image works fine just had to change the speed to 16000000 and all looks fine boots to piscreen now. I do have one problem thou when I go to raspi-config and expand the file system to use the hole 64gig SDCard it wont boot anymore gets past the resize on the terminal then stops at starting enhanced syslogd.

    Any suggestion's?

    #3649
    jawood
    Participant

    Update on image it seems to be quite unstable, kepp getting lock ups can you post how to manually setup the xwindows session to boot automatically please thanks

    #3676
    Mark Williams
    Keymaster

    Sorry for the late reply.
    Are you still having issue with the new image we uploaded?

    Is this what you are after?

    Force X windows to Load to PiScreen Automatically on boot

    To enable automatic login to X after boot, you will need to make a modification to two files.
    File one;

    pi@raspberrypi ~ $ sudo nano /etc/inittab

    Scroll down to
    1:2345:respawn:/sbin/getty 115200 tty1
    and change to
    #1:2345:respawn:/sbin/getty 115200 tty1
    and add this line
    1:2345:respawn:/bin/login -f pi tty1 /dev/tty1 2>&1
    File two;

    pi@raspberrypi ~ $ sudo nano /etc/rc.local

    And add the line below to the bottom of the file, just before the exit statement;

    su -l pi -c "env FRAMEBUFFER=/dev/fb1 startx &"

    Mark --OzzMaker.com --

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop...