Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #3083

    Now both xrdp and vino-server works, wonderful!


    This is the output of “cat /etc/modules”

    pi@raspberrypi ~ $ cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with “#” are ignored.
    # Parameters can be specified after the module name.

    flexfb width=320 height=480 regwidth=16 init=-1,0xb0,0x0,-1,0×11,-2,250,-1,0x3A,0x55,-1,0×36,0x28,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x0,0x0,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0×11,-1,0X29,-3
    fbtft_device debug=3 rotate=90 name=flexfb speed=24000000 gpios=reset:25,dc:24,led:22
    ads7846_device gpio_pendown=17 verbose=3 x_plate_ohms=100 pressure_max=255 swap_xy=1
    pi@raspberrypi ~ $

    and if I load the driver manually I get this message:

    pi@raspberrypi ~ $ sudo modprobe flexfb width=320 height=480 regwidth=16 init=-1,0xb0,0x0,-1,0×11,-2,250,-1,0x3A,0x55,-1,0×36,0×28,-1,0xC2,0x44,-1,0xC5,0x00,0x00,0x0,0x0,-1,0xE0,0x0F,0x1F,0x1C,0x0C,0x0F,0x08,0x48,0x98,0x37,0x0A,0x13,0x04,0x11,0x0D,0x00,-1,0xE1,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0xE2,0x0F,0x32,0x2E,0x0B,0x0D,0x05,0x47,0x75,0x37,0x06,0x10,0x03,0x24,0x20,0x00,-1,0×11,-1,0X29,-3
    FATAL: Module flexfb not found.

    So I ran this line and rebooted “sudo REPO_URI=https://github.com/notro/rpi-firmware rpi-update”
    That did the trick, somehow the drivers were uninstalled.


    One thing that I notice is that there are no /dev/fb1 in the /dev directory.

    If I run “sudo FRAMEBUFFER=/dev/fb1 startx” X11 starts on the hdmi screen.


    First, I guess both xrdp and vino-server uses the framebuffer (xrdp is a MS Remote Desktop compatible server and the vino-server is a VNC server for Xorg) so one or both of them probably sets some settings that makes things go back to hdmi, cause I have signal on that port.

    I include the dmesg output in the attached file.


Viewing 4 posts - 1 through 4 (of 4 total)

Blip, blop, bloop…