Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #3858

    Hi Mark

    I used the vanilla 2015-02-16-raspbian-wheezy.img from http://www.raspberrypi.org/downloads/


    I had the same problem as tarumaycry, but I eventually got it working. Maybe this will help:

    1. If this is a freshly installed image, run sudo rpi-update to get the latest firmware.
    2. Run sudo raspi-config. (or you can also do steps 3-6 on the initial raspi-config on a fresh image.)
    3. Go to 8 Advanced Options.
    4. Go to A5 Device Tree and choose “No” to disable the Device Tree, and “Ok” on the message saying “Device Tree will be disabled after a reboot”.
    5. Go back to 8 Advanced Options.
    6. Go to A6 SPI, and choose “Yes” to enable SPI kernel module to be loaded by default.
    7. Exit raspi-config and reboot.
    8. After reboot, edit the config.txt (sudo nano /boot/config.txt) and remove the line that says “device_tree=” if its there.
    9. Make sure there is a line that says “dtparam=spi=on“,
    10. Add the line “dtoverlay=piscreen,speed=16000000,rotate=90“.
    11. Save, exit and reboot.

    Hopefully that will get the PiScreen shining. ๐Ÿ™‚

Viewing 2 posts - 1 through 2 (of 2 total)

Blip, blop, bloop…