OZZMAKER SARA-R5 serial port issues

Home Forums Forums Technical Support for BerryGPS and BerryGPS-IMU OZZMAKER SARA-R5 serial port issues

Tagged: ,

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
  • #18121
    Alex Babij

    Well, as an update, I ended up buying a second module so I could rule out whether or not it was the module or the pi that was the source of the issues. The second module has the exact same issues/behavior as the first one, so clearly the issue is with the raspberry pi itself, and I unfortunately don’t have a second raspberry pi at the moment I can test it on. I tried a couple of different things now that it seems like the issue is on the pi’s end with the serial connection. I tried changing the baud rate around to 9600 instead of 115200, which had no effect unfortunately. I also tried running jumper wires to the module instead of plugging it straight into the pi in case there was some kind of signal noise/interference. That didn’t end up making a difference either.

    Any suggestions about where to go from here? I could try switching the uart to different pins which I think is possible to see if that changes anything.

    Mark Williams

    Hi Alex, sorry for the “radio silence”

    Over the last week or so, we have been trying to reproduce the problem… out of about 12 Pis, of all different types, we could reproduce it on one.  Right now, we are debugging the n_gsm kernel driver to see where it is failing.

    Regarding the garbage characters..Does this happen if you do not use ttyGMS1 at all?  E.g. use GMS2 for AT commands and GMS3 for steaming


    Mark --OzzMaker.com --

    Alex Babij

    The garbage characters still show up if I use either of those channels. My workaround has been if I just dont touch ttyGSM3 and immediately open cgps (or anything attached to gpsd) and dont close it, I wont have any issues. Makes me think it has something to do with gpsd letting go of serial channels when it doesn’t need them.

    I’ve unfortunately been having other issues as well, though. One of the modules, the gps doesn’t find any satellites, it can get the starting list from assisted gps, but the signal to noise ratio stays at 0 for all of them, it will occasionally jump up to 10 or so then go back down, even after leaving it for a long time. The other module will find and connect in around 20 seconds in the same exact location. Im guessing it might be some kind of issue with the antenna? I tried swapping the gps antenna between the two, and that didn’t change anything, so Im thinking maybe a bad connection between antenna and gps module? I dont know how to verify/fix that though.

    The other issue I am having is that the gyro data coming out of both of them is pretty noisy. The one with the gps issues has it fluctuate around +/- 5 deg/s on each of the axes, and the other one fluctuates around +/- 19 deg/s on the z axis and +/- 5 on the other two axes. Not really sure what could be causing that since the accelerometer and magnetometer are both putting out good data. I don’t think its a scaling issue, since if I rotate it 90 degrees, the corresponding gyro angle matches fairly closely. I am using the code straight from the github for this too. I tried changing the dps to +/- 500 (and swapped the gain to 0.0175 to match), but it was still pretty noisy at around +/- 4 deg/s on all axes.

    Any advice on either of those issues would be appreciated, Im not sure on how to diagnose the gps issue, and Im not sure if that level of noise out of the gyro is normal or not.



    Sound Good

    furniture stores


    Hi Alex

    Sorry for taking so long to get back to you. We know have a fix and we would love to have your feedback.

    1.make sure the kernel module n_gsm is running
    sudo modprobe n_gsm

    2. pull down the new mux software, enter into the directory and make

    git clone https://github.com/ozzmaker/gsmmux
    cd gsmmux

    You may get some warnings, you can ignore these.

    3. Run gsmMuxd, you should see output similar to below

    pi@raspberrypi:~/gsmmux $ ./gsmMuxd
    /tmp/ttyGSM0   Command Channel
    /tmp/ttyGSM1   Command Channel
    /tmp/ttyGSM2   GNSS Tunneling
    MUX started

    4.stop and then disable gpsd

    sudo systemctl stop gpsd.socket
    sudo systemctl disable gpsd.socket

    5. Start gpsd from the command prompt, point to the GNSS tunneling interface
    /usr/sbin/gpsd -n /tmp/ttyGSM2

    6.connect to command channel
    minicom 115200 -D /tmp/ttyGSM1

    7.Start GPS

    8. View GPS data

    Richard --OzzMaker.com --

Viewing 5 posts - 16 through 20 (of 20 total)
  • You must be logged in to reply to this topic.

Blip, blop, bloop…